Two CS undergraduates trying to build a prototype beowulf need help with bproc

Marcos Hiroshi Umino japa at
Sat Jun 14 16:12:28 EDT 2003

Hello friends.

We tried searching the mailing list archive, but the link on the beowulf
site was off, so we decided to try our luck and consult the oracles. :)

We are brazilian computer sciences undergraduates from the contryside of
Sao Paulo, in a city called Presidente Prudente.

Our computer sciences university is new and we are students of the first
class, so actually, we are making our lab. It is a great chance to play
around, so we two decided to team up and try to build a small prototype

We are not linux veterans, unfortunately, but we're trying hard and
doing some progress.

So, cutting down to our problem:

We installed redhat 8.0 in two machines, named master and slave1. We
setup nfs and rsh/rexec/rlogin and everything is working fine at kernel
level. We can rsh from/to slave1/master without any password prompts,
and pam looks ok too.

We installed the 3.2.4 bproc/beowulf kernel patch in kernel 2.4.20,
recompiled it and as it seems, everything looks fine.

We sucessfully modprobed vmadump and bproc, configured our master's
/etc/beowulf/config and all looked fine to go.

However, when we tried running bpmaster (as root) it started, then

Unfortunately, our guidebook is a brazilian translation, and I must
admit the translator wasn't very good at it. 

We are trying to search for complementary textbooks (we are students, so
books sugestions are great, but unfortunately are out of question). We
are a bit lost because the book we're following seems to use an outdated
beowulf version, because bproc docs seems to point toward no need for

Any sugestions, ideas, flames (those in pvt, pls) and the like would be
very welcome. :)

Thanks in Advance,

Marcos Hiroshi Umino <japa at>

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list