Data corruption w/ tg3 and bcm5700 drivers

Bogdan Costescu bogdan.costescu at
Tue Jun 3 14:32:34 EDT 2003

On Tue, 3 Jun 2003, Bryan K. Wright wrote:

> 	We've tried both the bcm5700 driver and a couple of versions 
> of the tg3 driver (1.2 and 1.5) with similar results.  We've tried the
> tg3 drivers with both the "stock" Red Hat 2.4.18-5 kernel (from RH
> 7.2) and with the openMosix 2.4.20-openmosix2 kernel.

RedHat has released several kernels after 2.4.18-5 and IIRC some were 
related to bugs in tg3 driver. The current one just released is 
2.4.20-18.7 (for 7.2).

> 	We find that, transferring large (multi-gigabyte) files from
> one machine to another results in either an error that aborts the
> transfer (at a random time) or, if the transfer completes, we find
> that the transferred file has the same size as the original, but
> their checksums (from /usr/bin/sum) differ.

This might also be a memory problem on one (or both) computer(s). Let 
memtest86 go through several cycles of its tests to make sure that this is 
not the case.

Bogdan Costescu

IWR - Interdisziplinaeres Zentrum fuer Wissenschaftliches Rechnen
Universitaet Heidelberg, INF 368, D-69120 Heidelberg, GERMANY
Telephone: +49 6221 54 8869, Telefax: +49 6221 54 8868
E-mail: Bogdan.Costescu at IWR.Uni-Heidelberg.De

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list