Linux support for AMD Opteron with Broadcom NICs

Martin Siegert siegert at
Tue Jul 1 18:48:08 EDT 2003


I have a dual AMD Opteron for a week or so as a demo and try to install
Linux on it - so far with little success.

First of all: doing a google search for x86-64 Linux turns up a lot of
press releases but not much more, particularly nothing one could download
and install. Even a direct search on the SuSE and Mandrake sites shows
only press releases. Sigh.

Anyway: I found a few ftp sites that supply a Mandrake-9.0 x86_64 version.
Thus I did a ftp installation which after (many) hickups actually worked.
However, that distribution does not support the onboard Broadcom 5704
NICs. I also could not get the driver from the broadcom web site to work
(insmod fails with "could not find MAC address in NVRAM").

Thus I tried to compile the 2.4.21 kernel which worked, but
"insmod tg3" freezes the machine instantly.

Thus, so far I am not impressed.

For those of you who have such a box: which distribution are you using?
Any advice on how to get those GigE Broadcom NICs to work?


Martin Siegert
Manager, Research Services
WestGrid Site Manager
Academic Computing Services                        phone: (604) 291-4691
Simon Fraser University                            fax:   (604) 291-4242
Burnaby, British Columbia                          email: siegert at
Canada  V5A 1S6
Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list