Linux support for AMD Opteron with Broadcom NICs

Mikhail Kuzminsky kus at
Mon Jul 23 12:44:16 EDT 2012

According to Martin Siegert
> Hello,
> I have a dual AMD Opteron for a week or so as a demo and try to install
> Linux on it - so far with little success.
> First of all: doing a google search for x86-64 Linux turns up a lot of
> press releases but not much more, particularly nothing one could download
> and install. Even a direct search on the SuSE and Mandrake sites shows
> only press releases. Sigh.
> Anyway: I found a few ftp sites that supply a Mandrake-9.0 x86_64 version.
> Thus I did a ftp installation which after (many) hickups actually worked.
> However, that distribution does not support the onboard Broadcom 5704
> NICs. I also could not get the driver from the broadcom web site to work
> (insmod fails with "could not find MAC address in NVRAM").
> Thus I tried to compile the 2.4.21 kernel which worked, but
> "insmod tg3" freezes the machine instantly.
> Thus, so far I am not impressed.
> For those of you who have such a box: which distribution are you using?
> Any advice on how to get those GigE Broadcom NICs to work?
  I may only add to the list of AMD64-oriented distributions
Turbolinux 8 for AMD64. I'm not sure that "promotional" version of
Turbolinux is complete enough, but "commercial" version costs
only about $70 (w/o support ;-)).

BTW, does somebody try it ?

We worked w/SuSE SLES8: it looks today as the only "reliable"
choice of 64-bit ditribution :-(

Let me congratulate our colleagues in USA w/4th July !

Mikhail Kuzminsky
Zelinsky Inst. of Organic Chemistry
Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list