[Beowulf] large array to run

Geoff Jacobs gdjacobs at gmail.com
Thu Dec 13 16:07:37 EST 2007

f.costen at cs.man.ac.uk wrote:
> Dear All,
> I am facing a very stange problem both g77 and ifort at the
> moment.
> When I try to use the array of
> integer actual(9915,9915,9915)
> in the test program which does not have
> any other arrays,
> the compilation works but
> when I tried to run it
> the program is immediately killed.
> I do not get any error message for that
> I tried this at our local cluster
> and the Univ's supercomputer and
> I get the same situation.
> If any of you in the list has this sort of
> problem and know the remedy for it
> can you let me have your idea ?
> Thank you very much
> Fumie

You do realize that array is utilizing almost a gig of ram. Do you have
that much available (physical and virtual)? Is your kernel configured to
allow that high a ram limit per process? What happens when the size of
one dimension is tuned down slightly?

Geoffrey D. Jacobs

Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf


More information about the Beowulf mailing list