[Beowulf] pvm and bproc 4.0

Dale Harris rodmur at maybe.org
Wed Jan 7 18:25:56 EST 2004

Thought I would try this list to see if anyone has some possible
insights.  Basically I'm trying to get PVM to work with bproc 4.0, but
having some problems.  Initially I was a having some little problems
with some node naming conventions changing with bproc 4.0, but I've
worked around those problems (instead of identifying nodes like .1 for
gethostbyname() they use n1).  However, the problem I've ran into now is
that I can get PVM to work with bproc 4.0 if I run PVM as root, but it
doesn't work for normal users.  Which is kind of a problem.  It appears
that pvm isn't able to access a socket, that it should be able to do.
So I see errors like:

[t80040000] 01/07 18:30:28 n-1 ( BEOSCYLD 3.4.4
[t80040000] 01/07 18:30:28 ready Wed Jan  7 18:30:28 2004
[t80000000] 01/07 18:30:32 stderr at n40: /proc/self/fd/3: /proc/self/fd/3:
Permission denied
[t80000000] 01/07 18:30:32 stdout at n40: EOF

fd3 points to a Unix socket.  Anyone have any insights?  PVM isn't
supported like it used to be, unfortunately.  

Dale Harris   
rodmur at maybe.org
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

More information about the Beowulf mailing list