[Beowulf] gigabit ethernet: horrible performance for 0 byte messages

Bernhard Wegner bwegner at ekt.tu-darmstadt.de
Wed Feb 11 05:02:23 EST 2004


I have a really small "cluster" of 4 PC's which are connected by a normal 
Ethernet 100 Mbit switch. Because the motherboards have Gigabit-LAN on board 
I thought I might be able to improve performance by connecting the machines 
via a Gigabit switch (which are really cheap nowadays).

Everything seemed to work fine. The switch indicates 1000Mbit connections to 
the PC's and transfer rate for scp-ing large files is significantly higher 
now, but my software unsing mpich RUNS about a factor of 4-5 SLOWER NOW than 
with the 100 Mbit switch.

I wasn't able to actually track down the problem, but it seems that there is 
a problem with small messages. When I run the performance test provided with 
mpich, it reports (bshort2/bshort4) extremely long times (e.g. 1500 us) for 0 
byte message length, while for larger messages everything looks fine (linear 
dependancy of transfer time on message length, everything below 300 us). I 
have also tried mpich2 which shows exactly the same behavior.

Does anyone have any idea?

Here are the details of my system: 
 - Suse Linux 9.0 (kernel 2.4.21)
 - mpich-
 - motherboard ASUS P4P800
 - LAN (10/100/1000) on board (3COM 3C940 chipset)
 - LevelOne 10/100/1000 8-port Fast Ethernet Switch (chipset: TC9208M +
   8x88E1111-BAB, AT89C2051-24PI)

Mit besten Grüßen -- Best regards,

Bernhard Wegner


   Dipl.-Ing. Bernhard Wegner

   Fachgebiet Energie- und Kraftwerkstechnik
   Technische Universität Darmstadt

   Petersenstr. 30      64287 Darmstadt      Germany

   phone: +49-6151-162357       fax: +49-6151-166555
   e-mail: bwegner at ekt.tu-darmstadt.de

Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

More information about the Beowulf mailing list