Linux support for AMD Opteron with Broadcom NICs

Florian Gabriel fgp at
Wed Jul 2 07:46:34 EDT 2003

Martin Siegert wrote:

>I have a dual AMD Opteron for a week or so as a demo and try to install
>Linux on it - so far with little success.
>First of all: doing a google search for x86-64 Linux turns up a lot of
>press releases but not much more, particularly nothing one could download
>and install. Even a direct search on the SuSE and Mandrake sites shows
>only press releases. Sigh.
>Anyway: I found a few ftp sites that supply a Mandrake-9.0 x86_64 version.
>Thus I did a ftp installation which after (many) hickups actually worked.
>However, that distribution does not support the onboard Broadcom 5704
>NICs. I also could not get the driver from the broadcom web site to work
>(insmod fails with "could not find MAC address in NVRAM").
>Thus I tried to compile the 2.4.21 kernel which worked, but
>"insmod tg3" freezes the machine instantly.
>Thus, so far I am not impressed.
>For those of you who have such a box: which distribution are you using?
>Any advice on how to get those GigE Broadcom NICs to work?
You can try the preview distribution "gingin64" from here:

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list