ethernet bonding problems

Glen Alan Kaukola gkaukola at
Fri Nov 1 00:45:00 EST 2002


I'm trying to set up ethernet bonding on two machines running RedHat 7.3.
In each machine I have two Netgear GA622T gigabit ethernet adapters.  I
also have two Netgear GS508T 8 port gigabit switches.  Eth0 in each
machine is hooked up to one switch and eth1 in each machine is hooked up
to the other switch.  I've tried two methods of bonding and neither seems
to quite work.

The first method I tried was to bring up a bond0 interface (aliased to
the bonding module in /etc/modules.conf) and then enslave both eth0 and
eth1 to it.  Both machines boot up, and I get the OK  on bringup up bond0,
eth0, and eth1 on each.  I do an lsmod and everything looks good.  I do
an ifconfig and everything looks good.  I try and ping one machine from
the other and anywhere from 40 to 70 percent of my packets get lost.  Ssh
between the two machines works but it is slow as heck.

So, I gave up on the first method and tried a second method.  This time I
only configured one of the network cards on each machine.  Once the
machines were booted I ran a 'modprobe bonding' on each.   Next I ran the
command 'ifenslave eth0 eth1' on each.  Again, I checked out the
output of lsmod and ifconfig and everything looked great.  I tried
ping again and this time I did't get any packet loss so I thought I was
set.  But when I tested the connection with ttcp the speed was no
different than when I had just one ethernet adapter per machine.  I ran
the test again and noticed that lights on only one of the switches were
blinking.  So this method seems to have failed too.  I got to thinking
tonight though that perhaps this is normal and I'd get better results if I
had more than one application using the network at a time?  I guess I'll
play with that tommorow.

In the meantime, I would really appriciate it if anyone could provide me
any help or advice to get this working.  And one other thing, in talking
to someone on irc I was informed that ethernet bonding would not work at
all with two seperate switches like I have and would only work with a
managed switch.  A whole lot of the things I've read though on web pages
say otherwise.  So I'm wondering who's right?

Thanks in advance,

Glen Kaukola

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list