Can't format 2nd hard drives on slave nodes in Scyld

Tony Stocker akostocker at
Wed Oct 10 15:31:17 EDT 2001

Greetings all,

Well since the last time I posted, I received a copy of the latest Scyld 
(ver. 27BZ-8) from Linux Central.  Using this I didn't have any problems 
with the my 3Com cards or with loading any modules on the host node.  

I had some problems at first getting the slave nodes to install, but finally 
got beofdisk to format the primary hdd (/dev/hda) on the slave node.

However, the slave nodes have a second hdd as well (/dev/hdb) and I can not 
seem to get beofdisk to do anything to them.  I have created a mapping file 
hdb:4865:255:63 (I modeled it after the working file for the hda hard drive) 
in the same location the mapping file for /dev/hda is, but I can't seem to 
get beofdisk to do anything except fdisk /dev/hda.

I have tried using bpsh to manually sfdisk the drive, but after launching 
the command: `bpsh -n 0 sfdisk /dev/hdb`  all I get is something along the 
lines of: "Checking to see if anyone is using this disk <CR> OK" and then 
nothing, it appears to hang.  I've tried redirecting input to the sfdisk 
command via a file but the same thing occurs.  I've left the process alone 
for several hours but nothing ever happens.

Now aside from manually booting each node with a mini-root floppy and 
manually fdisk & mke2fs each drive (24 nodes), is there ANY way from the 
host node in a Scyld beowulf to format (fdisk/mkfs) these secondary hard 

-Tony Stocker
akostocker at
astocker at

Get your FREE download of MSN Explorer at

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list