[Beowulf] error while make mpijava on amd_64

Mark Hahn hahn at mcmaster.ca
Wed Mar 3 15:05:01 EST 2010


>    we r not getting latest free download version for mpijava for linux for

this is version 1.2.5 circa jan 2003, right?  right away this should 
set off some alarms, since any maintained package would have had some 
updates since then.  it's slightly unreasonable to expect such an old
package, especially one which is inherently "glueware" to be viable 
after sitting so long.

> AMD 64 bit. Also can u suggest the solution n for the error i forwarded.ur
> explaination is not very clear 2 me..:(

using a static library would be easy ("ar r mpijava.a *.o"), but now 
that I give it another thought, you probably want this to act as a 
java extension, which probably requires being a shared library.

in principle, to get the .so to work, you need to add -fPIC to each 
of the component compiles (which produce .o files), then add -shared
to the last link-like stage which combines the .o files into a .so file.
you'll have to look at the Makefile to find out where to add these 
flags.  offhand, I'd think you should add -fPIC to CFLAGS and -static 
to LDFLAGS (but I don't have a copy of the Makefile.)

as a testament to the whimsical nature of getting 2003-vintage software
to compile, I can't even find a working download link for mpijava.
web sites also wither and die if not cared for...

-mark
_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org sponsored by Penguin Computing
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list