[Beowulf] SuperMicro and lm_sensors

Karen Shaeffer shaeffer at neuralscape.com
Thu Jun 19 10:40:38 EDT 2008


On Thu, Jun 19, 2008 at 08:24:38AM +0100, John Hearns wrote:
> On Wed, 2008-06-18 at 15:11 -0700, Greg Lindahl wrote:
> > Speaking of lm_sensors, does anyone have configs for recent SuperMicro
> > mobos? My SuperMicro support contact doesn't have ay idea, and running
> > sensors-detect leaves me with lots of readings which are
> 
> Can't help you on the lm_sensors front, we always use IPMI these days.
> But hearing of miscalibrated values does not surprise me.

Hi John,
Yes, miscalibrated values and even the mapping of labels to
expected devices can be in error, even when the lm_sensors
subsystem is fully operational. This is inherent in the architecture
of the system, if you will. The configuration file must have
information specific to the system board implementation, rather
than merely related to specific sensor chips. The generic configuration
files found in distributions often are not correct (even if they
look reasonable) for specific system boards.

And, if you are attempting to support an appliance product line,
where there are numerous system boards in various appliances,
then this becomes quite a chore to manage, due to the architecture
of lm_sensors subsystem. IPMI is clearly a better way to go. But
lm_sensors can always be made to work, it just requires some in-house
expertise in many cases.

Thanks,
Karen
-- 
 Karen Shaeffer
 Neuralscape, Palo Alto, Ca. 94306
 shaeffer at neuralscape.com  http://www.neuralscape.com
_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.



More information about the Beowulf mailing list