[Beowulf] Re: wajig for Ubuntu/Debian package management

Tim Cutts tjrc at sanger.ac.uk
Sat Feb 16 03:44:13 EST 2008


On 15 Feb 2008, at 11:57 pm, Andrew Piskorski wrote:

> Those are good hints...
>
> Debian and Ubuntu have excellent package management functionality and
> and repositories (as good or better than any other major Linux or Unix
> distribution, AFAIK), but strangely, by default they have no
> consistent API or command set for using it.  Therefore, I recommend
> trying out wajig:
>
>  sudo apt-get install wajig
>  http://www.togaware.com/linux/survivor/Wajig_Overview.html
>
> It's really just a wrapper (in Python) around all the same underlying
> command-line tools, but in my limited use of it so far, it seems
> noticeably more convenient than the traditional bizarre, non- 
> orthogonal
> mishmash of apt-get, dpkg, apt-cache, apt-file, etc.
> (I don't know if/how it compares to aptitude, I've never used that.)

aptitude has pretty much the same CLI as apt-get, and all of the APT  
family are fairly consistent.  dpkg is different, of course, but then  
it's much older.  It was also written by Ian Jackson, who's a very  
nice guy (and a friend of mine) but who has a tendency to write user  
interfaces which don't correspond to the brains of most people.  :-)   
Just kidding, Ian, if you read this.  dpkg, actually, I find quite  
nice (nicer than rpm anyway, but that's probably just because I'm used  
to it).  dselect, Ian's wrapper around dpkg, really is a UI nightmare  
though, and should really be quietly taken out into the woods and  
shot.  I think there are plans to remove it from Debian, but it hasn't  
happened yet.  dselect's hideousness is a large part of why aptitude  
exists.

> The Debian package management tools don't seem to have any sane
> programming API, but so far I haven't really needed that (and wajig
> manages to do without).

There are some perl modules, I think, but they're not well  
documented.  I've never needed them either.

>
> Their only other major flaw that I'm aware of, is that, just like all
> the rpm based tools, you can only have one single version of a binary
> package installed at a time (yuck!).

That's not true.  Look at the gcc or emacs packages.  Or automake.  Or  
autoconf.  Many, many versions, all of which can coexist on your  
system at the same time, and you can use update-alternatives to choose  
which one is the default.  The trick is that the packages have to have  
different names, so in the case of gcc there are gcc-3.3, gcc-3.4,  
gcc-4.1 etc.  In the more obvious cases where people are going to want  
to have the choice, this has already been done.  Of course there are  
plenty of cases where it hasn't, and then yes, you're right, you can't  
have more than one at once.  But Debian does have the infrastructure  
to support it.


>  Perhaps one day, the sort of
> tools the NixOS and DragonFly BSD folks are working on will fix that.
>
>  http://nix.cs.uu.nl/index.html
>  http://lambda-the-ultimate.org/node/2176
>  http://www.dragonflybsd.org/docs/goals.shtml#packages
>
> -- 
> Andrew Piskorski <atp at piskorski.com>
> http://www.piskorski.com/
>
>



-- 
 The Wellcome Trust Sanger Institute is operated by Genome Research 
 Limited, a charity registered in England with number 1021457 and a 
 company registered in England with number 2742969, whose registered 
 office is 215 Euston Road, London, NW1 2BE. 
_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

!DSPAM:47b6a2c737832889862676!



More information about the Beowulf mailing list