[Beowulf] Re: PVM on wireless...

David Mathog mathog at caltech.edu
Wed Feb 6 16:01:22 EST 2008


> Anybody on list have any idea why PVM fails to add hosts over a wireless
> link?  I've now tried this over multiple distro version and at least one
> PVM update, and it just doesn't work.  Works fine over a wire, fails on
> wireless, and as far as I know wire and wireless are both "identical"
> at the kernel interface layer so that any e.g. socket one might open is
> absolutely ecumenical about what the underlying hardware is (good old
> ISO/OSI layering, right?).

Sounds like multiple network hell, with some type of name mismatch
causing the problems.  Start up pvmd directly on one of the wireless
machines and then use pvm to see what it calls itself.  If that
differs in any way from the entries in your host list then that is
probably the problem.  If they come up the same then run -d settings on
pvmd to find out more information.

It is also possible the firewall settings are different, and the wired
interface allows pvm connections in some way that the wireless does not.

Did you try starting pvmd on a pure wireless machine and see if it can
connect to other pure wireless machines?  It would be good to get the
wired interfaces completely out of the equation.

Regards,

David Mathog
mathog at caltech.edu
Manager, Sequence Analysis Facility, Biology Division, Caltech
_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

!DSPAM:47aa2091290883122173853!



More information about the Beowulf mailing list