[Beowulf] Weird CentOS Install Problem

Jess Cannata jac67 at georgetown.edu
Mon Aug 11 15:40:45 EDT 2008


Jon,

I have had the same problem. You should double-check that the non-80 GB 
volume has a GPT type partition table set. To see your current partition 
table setting, run parted /dev/<your_volume> and then "print." You 
should see something like this:

parted) p
Disk geometry for /dev/sde: 0.000-2626094.625 megabytes
Disk label type: gpt
Minor    Start       End     Filesystem  Name                  Flags
1          0.017 2626093.625  ext3

I've noticed that Red Hat's Anaconda will create an MS-DOS partition 
table on the disk even though MS-DOS partition tables cannot support 
greater than 2 TB volumes. You can use "parted" to change it to GPT via 
the mklabel option. Then you can create the ext3 file system.

-- 
Jess Cannata
Advanced Research Computing &
High Performance Computing Training
Georgetown University



Jon Forrest wrote:
> I thought maybe some of you cluster people might have
> seen this.
>
> I have a brand new machine that will be the frontend
> of a cluster. It has a 3ware 9650 12-port RAID controller
> with 12 1TB drives attached.
>
> I used the "Boot Volume" feature in the RAID controller
> to make an 80GB boot volume. I install CentOS 5.2 x86_64
> on this and everything installed fine, except ...
>
> When I boot the newly installed machine it stops in
> the grub prompt. If I type by hand the commands in
> /etc/grub.conf (which I saw by booting from a rescue CD),
> the first command "root (hd0,0)" shows that an ext3 partition
> was recognized, as it should. However, when I enter the
> "kernel ...." command, I get the following error message:
>
> Error 18: Selected cylinder exceeds maximum supported by BIOS
>
> What's weird about this is that the root file system starts
> on cylinder 1, as confirmed by the fdisk command. This is
> using a brand new SuperMicro X7SBE motherboard with the
> newest BIOS.
>
> What's even weirder is that the integrator that I purchased
> the system from somehow managed to install CentOS 5.
> I saw it boot the first time I turned on the system.
> I deliberately wiped it out. Needless to say, I have
> a message in to them.
>
> Any ideas could cause this?
>
> Cordially,


_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list