[Beowulf] Strange hardware? problems

Orion Poplawski orion at cora.nwra.com
Fri Apr 27 13:17:57 EDT 2007


I'm at a loss and trying to see if anyone else has had similar problems.

We've got two pairs of identical machines:

- 2 Tyan S2882 dual processor Opteron 244 stepping 10
- 2 Tyan S2882-D dual processor dual core Opteron 275 stepping 2

We have two (relatively complicated) numerical models (RAMS and a 
homegrown one) that will blow up in random locations on the 244 machines 
but run fine on the 275 machines.

By blow up it appears the calculations get corrupted in some way and the 
numbers get un-physical in RAMS and the simulation exits.  With the 
other model we get segfaults.

Memtest86 runs fine.  No other hardware issues that I can find.

We've tried FC4/5 on the 244 machines.  At one point all were running 
identical FC5 installs with the same problems.

Problem is not exactly reproducible unfortunately.  It will crash at 
different times in the simulations, but they will crash at some point 
with the length of runs we are doing.

Are there any cpu tests out there that would check the accuracy of 
various calculations?

Thanks!

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  orion at cora.nwra.com
Boulder, CO 80301              http://www.cora.nwra.com
_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

!DSPAM:463230e5163158362916074!



More information about the Beowulf mailing list