[Beowulf] Need help on running mpi on different hosts

Toon Knapen toon.knapen at fft.be
Fri Apr 20 17:47:51 EDT 2007


But probably  both boxes are only connected with an ethernet, right. Or 
is there the SGI interconnect (can not remember the name now) also 
between both boxes ?

t

Aydin Misirlioglu wrote:
> Hi, 
> 
> I have a problem about running mpi on 2 SGI IRIX mavhines. I have 1
> Origin2000 machine with 4 processors and 1 Origin3000 with 32 processors.
> Mpi is running on array services on both nodes. When I try to run my program
> on one machine it works ok. For example
> 
> "At first_node : mpirun -a my_array second_node 2 my_code" works,  
> "At second_node : mpirun -a my_array first_node 2 my_code" works as well.  
> 
> But whenever I run the code on both nodes using 
> 
> mpirun -a my_arrray first_node, second_node 2 my_code 
> 
> it doesn't work. Mpirun spawns the codes on both nodes but does not execute
> anything. I have no problem on accessing the remote nodes, I set all the
> necessary array authentication options properly, .rhosts, hosts.equiv files,
> etc. as suggested by mpirun man pages. I compiled the code at each node and
> set the directories correctly. Even the example "Hello World" program does
> not run. 
> 
> Any help on this issue will be greatly appreciated, 
> 
> Regrads, 
> 
> Kahize, 
> 
> 
> 
> _______________________________________________
> Beowulf mailing list, Beowulf at beowulf.org
> To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

!DSPAM:4629356d222228298414181!



More information about the Beowulf mailing list