[Beowulf] Problem using mpich2 and scalapack

Ivan Paganini ispmarin at gmail.com
Mon Mar 6 17:39:30 EST 2006


Hello everybody! My first time here at beowulf list, and hope some
bright soul will help me!

I am trying to use at the same time some mpich2 routines and
scalapack. My code is written in fortran90, and I am using pgi
compilers to compile everything. Lapack and blas are from acml 2.5.0.
First, I ran on mpich2 instalation directory
export F90=pgf90
export F77=pgf90
export CC=pgcc
export CXX = pgCC
and
./configure --prefix=/opt/mpich2-1.0.3  --enable-f90 --enable-f77
make and make install. Ok.
Then on BLACS directory, set the mpich library to libmpich.a (from
mpich2 installation) and compiled with pgf90. Ok. Ran tests, ok.
Then compiled Scalapack with libmpich.a and blacs. Ran tests, ok.
Then, compiled my program, and ran it. Got the message:

Users with C main programs must explicitly call MPI_Init

As I said, my program is fortran! So, is there a problem with the
calls of libmpich.a (should I use libfmpich.a, libmpichf90.a?) or some
call in my program?

When I put the MPI_Init on the program, I got segfaults (signal 11) on
the first mpi routine that is being used (in case, MPI_BCAST), but
none errors on the blacs routines. It is a problem in context, maybe?

Right now I am compiling again blacs and scalapack with the
libfmpich.a and will see if it works. Meanwhile, if someone can
help...

Thank you!

-----------------------------------------------------------
Ivan S. P. Marin
Laboratório de Física Computacional
lfc.ifsc.usp.br
Instituto de Física de São Carlos - USP
----------------------------------------------------------

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list