[Beowulf] Re: [MPICH] EOF from console

Matthew Fowler tjue1 at central.susx.ac.uk
Thu Jun 15 09:30:35 EDT 2006


Hi Philip.

The boards actually have two LAN interfaces. I tried bringing down the 
2nd like you suggested, but I have the same problem.

Here is the output of mpdcheck -v, I get the same respective output from 
all the boards im using:

# mpdcheck -v
mpdcheck -v
obtaining hostname via gethostname and getfqdn
gethostname gives  board01
getfqdn gives  board01
checking out unqualified hostname; make sure is not "localhost", etc.
checking out qualified hostname; make sure is not "localhost", etc.
obtain IP addrs via qualified and unqualified hostnames;  make sure 
other than 127.0.0.1
gethostbyname_ex:  ('board01', [], ['10.9.10.1'])
gethostbyname_ex:  ('board01', [], ['10.9.10.1'])
checking that IP addrs resolve to same host
now do some gethostbyaddr and gethostbyname_ex for machines in hosts file
#

Does that look right to you? I cant see anything wrong.

Oh yes im using a good Netgear Fast Ethernet Switch (just a little 8 port)

Best Regards

Matthew

Philip Sydney Lavers wrote:

>Hello Mathew,
>How many LAN cards per board? If more than one try ifconfig down on the card that is not meant to be in the ring.
>Also check that hostname on each board is actually what mpd thinks it is. 
>Also are using LAN hub or switch?
>
>regards,
>
>Philip Lavers
>
>---- Original message ----
>  
>
>>Date: Mon, 12 Jun 2006 16:49:08 +0100
>>From: tjue1 at sussex.ac.uk  
>>Subject: [MPICH] EOF from console  
>>To: beowulf at beowulf.org, mpich-discuss at mcs.anl.gov
>>
>>Hi list 
>>
>>Im doing some experiments on an embedded platform and am building a 
>>Beowulf cluster from them. I have a unusual setup as the boards have 
>>limited memory and i am using MPICH 2 (latest). The setup is a bit 
>>strange as Python is accessable to the boards via an NFS mount. 
>>
>>I can start an MPD daemon on a single board with no problems. I can 
>>also add a further three to the ring with no probs. Adding a fith 
>>causes an error. (see below) 
>>
>>(im adding nodes manually rather than using mpdboot. When I get it 
>>working manually I will get mpdboot working. 
>>
>>Heres the problem: 
>>
>>(from first board) 
>>
>>mpdtrace -l 
>>board01_2048 (10.9.10.1) 
>>
>>I then add others into the ring as: 
>>
>>mpd -h board01 -p 2048 & 
>>
>>mpdtrace 
>>board02 
>>board01 
>>
>>I can continue to add boards until I try and add a 5th. When adding a 
>>5th using the above method I get: 
>>
>>mpdtrace & 
>>mpdtrace (mpdtrace 57): got eof on console 
>>Jul 22 08:33:49 board05 python2.3: mpdtrace (mpdtrace 57): got eof on 
>>console 
>>
>>I have to admit im baffled. Can anyone shed some light on this? If more 
>>specific information will help please tell me. 
>>
>>Regards 
>>
>>Matthew 
>>
>>
>>    
>>

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list