[Beowulf] Clusters and Distro Lifespans

Mike Davis jmdavis1 at vcu.edu
Wed Jul 19 11:35:41 EDT 2006

hahn at physics.mcmaster.ca wrote:
> I think it's more a matter of taste/comfort.  I hate running a kernel
> that's more than 6 months old, since I'm often aware of problems fixed
> during that time, etc.  if your distro has only a 2.4 kernel, for instance,
> IMO, you are losing quite a lot.  if your distro has a 2.6.9 kernel,
> you're still missing, for instance, sata smart support.

The question for me is: does VASP, G03, Fluent, LAMMPS, GAMESS, BLAST, 
or FASTA need that kernel. If the answer is yes, ok. Otherwise, let the 
cluster run the jobs it needs.

The researchers don't care what distro we run as long as it works and 
lets them do their work. The work is the important thing.

As was previously noted, security patches on the head node(s). We also 
try to make sure that we can run the applications that we need. If its 
not necessary the newest kernel is no better than that oldest that 
works. In our case, we have too much work and too ofew people to do 

Mike Davis
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

More information about the Beowulf mailing list