[Beowulf] mpich program segfaults

Suvendra Nath Dutta sdutta at deas.harvard.edu
Wed Mar 3 14:42:13 EST 2004


Glen,
	Does your program seg fault when compiled with debugging off or on? 
Sometimes compilers will initialize arrays when compiling for 
debugging, but not waste time doing that when compiled without 
debugging. Also if you compile with optimization which line follows 
which one isn't always clear. You want to make sure you aren't 
over-running memory. Because what you say sounds suspiciously like 
that. Also you want to be sure its nothing to do with MPICH. Try 
calling the subroutine from a serial program if possible.
				Suvendra.

On Mar 3, 2004, at 12:52 PM, Glen Kaukola wrote:

> Hi,
>
> Sorry if this is off topic.  Anyway, I've got an mpich Fortran program 
> I'm trying to get going, which produces a segmentation fault right at 
> a subroutine call.  I put a print statement right before and right 
> after the call and when I run the program, I'm only seeing the one 
> before.  I've also put a print statement right at the beginning of the 
> subroutine which is being called and never see that either.  The real 
> strange part is when I run this under a debugger, the program runs 
> fine.  So would anyone happen to have any insight to what's going on 
> here?  I'd really appriciate it.
>
> Thanks,
> Glen
> _______________________________________________
> Beowulf mailing list, Beowulf at beowulf.org
> To change your subscription (digest mode or unsubscribe) visit 
> http://www.beowulf.org/mailman/listinfo/beowulf


_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list