[Beowulf] i have problem in my beowulf

prakash borade proksy_me at yahoo.com
Fri Jan 2 03:27:20 EST 2004


hello everybody

          i am very new to clustering environ ment and
also to beowulf

i need some guid in how to build a beowul cluster

i m trying it with mpich 1.2.5.2

is it neccesary to initialize the lam environmnet

what i know is that lam/mpi and mpich   are to
diffrent implementtations of mpi

i get following error for the standard cpilog program
after  i have initialized lam environment using
lamboot

[mpich at tung mpich]$ mpirun -np 2 cpilog
Process 0 running on tung
Process 0 running on dyp
pi is approximately 3.1415926535897634, Error is
0.0000000000000298
wall clock time = 0.768179
-----------------------------------------------------------------------------
It seems that [at least] one of processes that was
started with mpirun
did not invoke MPI_INIT before quitting (it is
possible that more than
one process did not invoke MPI_INIT -- mpirun was only
notified of the
first one, which was on node n0).

mpirun can *only* be used with MPI programs (i.e.,
programs that
invoke MPI_INIT and MPI_FINALIZE).  You can use the
"lamexec" program
to run non-MPI programs over the lambooted nodes.
-----------------------------------------------------------------------------

__________________________________
Do you Yahoo!?
Find out what made the Top Yahoo! Searches of 2003
http://search.yahoo.com/top2003
_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list