[Beowulf] mpich on OS X

Glen Beane beaneg at gandalf.umcs.maine.edu
Wed Aug 25 16:08:57 EDT 2004


I'll look through my logs more closely, but at quick glance it doesn't 
look like any problems occur until it tries to link.  I have no problems 
using 1.2.5, but this is a different machine (in fact I don't have 
access to the other OS X machine I previously compiled 1.2.5 on), so I 
figured I'd start with the latest source, since I have to compile anyway 
(plus 1.2.6 was supposed to have better OS X build support).

I probably will try MPICH2  as well.

Joachim Worringen wrote:

> Glen Beane wrote:
>
>> I've compiled mpich-1.2.5 on a different OS X 10.3 system with xlf and
>> gcc without this problem. I tried using xlf and gcc now, with no change
>> in the behavior. I'm using very generic ./configure arguments
>> (--with-device=ch_p4, -prefix=~/mpich, -opt=O2, --disable-c++), and i'm
>> not passing any extra flags to the compilers or linker (which I'm
>> assuming is my problem).  Anyone know the linker/compiler flags I need
>> to get this to link properly? 
>
>
> - Take a look on the output of the compilers (make >&make.log; less 
> make.log). Probably there's a problem with some files in 
> mpid/ch_p4(/p4) to compile correctly. Knowing the actual problem makes 
> it easier to fix.
>
> - Why do you need mpich-1.2.6 - it's mostly a bugfix release of 1.2.5. 
> Do you see any bugs with 1.2.5?
>
> - What about MPICH2? Performs significantly better with socket 
> communication.
>
>  Joachim
>

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list