[Beowulf] mpich on OS X

Glen Beane beaneg at gandalf.umcs.maine.edu
Wed Aug 25 11:22:43 EDT 2004


I'm currently trying to build mpich-1.2.6 on OS X 10.3.5 using xlf 8.1
and xlc 6.0 and I get the following error at the linktest phase of the
make process:

mpich-1.2.6/bin/mpicc  -o overtake overtake.o test.o
/usr/bin/ld: Undefined symbols:
_execer_mastport
_local_domain
_p4_global
_listener_info
_whoami_p4
_globmemsize
_logging_flag
_sserver_port
_execer_mynodenum
_p4_local
_p4_myname_in_procgroup
_p4_brdcst_info
_p4_debug_level
_execer_starting_remotes
_hand_start_remotes
_p4_remote_debug_level
_bm_outfile
_p4_wd
_execer_pg
_procgroup_file
_execer_masthost
_execer_id
_execer_numtotnodes
_execer_mynumprocs
_execer_myhost
_p4_rm_rank
_rm_outfile_head
make[4]: *** [overtake] Error 1
make[3]: [linktest] Error 2 (ignored)
Could not link a C program with MPI libraries
make[3]: *** [linktest] Error 1
make[2]: *** [linktest] Error 2
make[1]: *** [mpi-lib-test] Error 2
make: *** [mpi] Error 2


I've compiled mpich-1.2.5 on a different OS X 10.3 system with xlf and
gcc without this problem. I tried using xlf and gcc now, with no change
in the behavior. I'm using very generic ./configure arguments
(--with-device=ch_p4, -prefix=~/mpich, -opt=O2, --disable-c++), and i'm
not passing any extra flags to the compilers or linker (which I'm
assuming is my problem).  Anyone know the linker/compiler flags I need
to get this to link properly? 

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list