[Beowulf] PVM does not spawn to other nodes

Timo Mechler mechti01 at luther.edu
Wed Aug 4 00:43:30 EDT 2004


Hi,

Are you sharing the pvm or home directory via NFS etc. from one machine to
other nodes so that you don't have to compile the code on all nodes?  If
not, did you properly compile the hello/hello_other programs et all on
each node?  I'm pretty new to PVM as well but thought I'd give you some
things to check.  Hope this helps.

-Timo Mechler


>
>
> PVM 3.4.4  on Linux/x86
>
> My PVM starts up fine (it uses ssh), hosts can be successfully added.
> However, when I run the provided test jobs
>
> hello/hello_other
> hitc/hitc_slave
> master1/slave1
>
> They all return errors, and the errors indicate PVM fails to spawn the
> process
>
> hello:
> i'm t4000b
> can't start hello_other
>
> master1:
> Spawning 9 worker tasks ...
>  Trouble spawning slaves. Aborting. Error codes are:
> TID 0 -7
> TID 1 -7
> TID 2 -7
> TID 3 -7
> TID 4 -7
> TID 5 -7
> TID 6 -7
> TID 7 -7
> TID 8 -7
>
> hitc:
>  3 hosts detected in configuration
>  Error in spawn. info= 0
>  tid 0 -7
>  tid 1 -7
>  tid 2 -7
> libpvm [t4000e]: pvm_mcast(): Bad parameter
>
>
> Any idea of what went wrong?
>
>
> Another thing, I dont know if it's relevent.
> I am using the PVM source from FC2/AMD64 RPM, which has some AMD64
> definitions. But on x86, there should be no difference.
>
> Thanks,
> Alan.
>
> _______________________________________________
> Beowulf mailing list, Beowulf at beowulf.org
> To change your subscription (digest mode or unsubscribe) visit
> http://www.beowulf.org/mailman/listinfo/beowulf
>


-- 
Timo R. Mechler
mechti01 at luther.edu
(563) 382-7918

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list