Problems with Mii-Diag...

john152 at john152 at
Wed Mar 12 13:38:02 EST 2003

Hi all,
first of all thanks for your answers to my previous mail.

I installed mii-diag and i think there are problems:
I used two PC (PC1 with a Network Card 3Com 3C900 B Combo and a DEC 21142; PC2 with two Network Card 3Com 3C900 B Combo ). 
I tried two configurations: PC connected together  by two 3C900 with a cable and PC connected by an HUB, with the HUB in the root of the configuration ( PC1---HUB---PC2 ) using the two 3C900.

I used only the 3C900 because with the DEC i have this line:
" # ./mii-diag eth0 
  # SIOCGMIIPHY on eth0 failed: Operation not supported".

In the two configurations (for both ping was OK!) i had the same line from mii-diag:

"#./mii-diag -w
Using the default interface 'eth0'.
 Basic registers of MII PHY #0:  0000 ffff 0000 ffff 0000 ffff 0000 ffff.
 The autonegotiated capability is 0000.
No common media type was autonegotiated!
This is extremely unusual and typically indicates a configuration error.
Perhaps the advertised capability set was intentionally limited.
 Basic mode control register 0x0000: Auto-negotiation disabled, with
 Speed fixed at 10 mbps, half-duplex.
 Basic mode status register 0xffff ... ffff.
   Link status: established.
 Remote fault detected!
   *** Link Jabber! ***
 Your link partner advertised ffff: Flow-control 100baseT4 100baseTx-FD 100baseTx 10baseT-FD 10baseT, w/ 802.3X flow control.
   End of basic transceiver information.
No MII transceiver present to minitor.

I had eth0 configured and active!
I'm using RedHat 8.0. 

Using mii-tool i have:
eth0: 10 Mbit, half duplex, link ok
eth1: 10 Mbit, half duplex, link ok

Can you help me please? What does mii-diag mean for 'MII tranceiver'?
Thanks in advance for your kind answer.

Giovanni Di Giacomo

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list