Network Boot Problems

Curtas, Anthony R. ANTHONY.R.CURTAS at saic.com
Fri Jan 3 14:44:47 EST 2003


Hello,
I am trying out OSCAR on a second cluster of four identical machines.  They
are Gateway 2.4GHz towers with integrated ethernet.  The head node has a PCI
Linksys ethernet card on eth1.

The OSCAR version is 2.1, the linux version is RedHat 7.3.  After the
initial collection of MAC addresses (the nodes try to network boot), I
restart the DHCP server and reboot the nodes.  They initially fail to "hear"
anything and timeout on the tftp request.  So I restart the xinetd daemon
and reboot the nodes.  Now they get the ip address and network info, but
when it comes time to load the boot image, it give three file not found
errors.

Upon further research, it appears that there should be something in the
/tftpboot directory other than the rpms, but that's all that the OSCAR
installation scripts put in there (I put in the RedHat rpms, it put in the
OSCAR rpms).  Shouldn't there be a boot image in this directory?  Should my
tftp configuration point to another directory?

Here is the network boot error (after all the CLIENT MAC ADDR, CLIENT IP,
and GATEWAY IP messages):
TFTP.
PXE-T01: File not found
PXE-E3B: TFTP Error - File Not found
PXE-M0F: Exiting Intel Boot Agent
Boot failure: System Halted

Please help.

Anthony

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list