Problem with MPICH and Intel and PGI Compilers on Linux

Joseph Landman landman at scalableinformatics.com
Tue Feb 4 08:53:21 EST 2003


Hi Jeff:

  Going on some old memory here, but I seem to remember that the PG 
compilers had a switch which allowed specific linking against GNU 
libraries.  I presume that the Intel compiler has similar options.  My 
initial guess is that there are ABI differences across the libraries. 
 If you can set up a machinefile so as to run all the code in multiple 
threads on a single machine, you might be able to see this (especially 
if you attach a debugger to the process).  

   The GNU linkage options at least get them speaking the same ABI 
(hopefully, as there are differences between 2.96 and 3.x (x<2) and 3.x 
(x>2).

    See if you can find those option for PG, and Intel.  Retry the 
builds.  See if the error moves.

Joe

Jeff Layton wrote:

>Good morning,
>
>   I'm having trouble with my MPI code using MPICH-1.2.4 or 1.2.5 and
>the Intel Fortran/C compilers for Linux (v. 6.0 and 7.0 of the compilers)
>and the PGI compilers for linux (v4.0.2).
>  
>

-- 
Joseph Landman, Ph.D
Scalable Informatics LLC,
email: landman at scalableinformatics.com
web  : http://scalableinformatics.com
phone: +1 734 612 4615



_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list