eepro100 confusion

Donald Becker becker at scyld.com
Thu Oct 24 12:30:31 EDT 2002


On Wed, 23 Oct 2002, rqueneau wrote:

> I recently had two IBM Linux clusters installed at my work site. Due to
> certain customer issues, our cisco switches have all ports set to 100Mbits
> Full Duplex for all server connections. When I monitor the port that the
> head node uses I find lots of errors, i.e. CRC's, Runts, etc...

Yup, likely a duplex mismatch.

> I have found many configuration articles for the eepro100 that talk
> about using the options statement in the /etc/modules.conf file. The
> problem is that these articles are inconsistant.

Use the one provided by your cluster software vendor...   oh, they
didn't provide any documentation on the networking interface, did they?
No matter, networking can't be that important to a cluster... just use
it without the network.  (Sorry, just had to get that one in.)

> One says to use options=0x30, another says use
> 0x200 and yet another says use 0x2100. Which one is correct?

It depends on the driver you are using.  I'm guessing that you are using
an eepro100 driver modified from my original release, and thus it's
difficult to guess what interface that it uses.
You _should_ be able to run 'mii-diag' to find the current setting, and
you might even be able to set the duplex with 'mii-diag -F 100baseTx-FDX'.

-- 
Donald Becker				becker at scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Scyld Beowulf cluster system
Annapolis MD 21403			410-990-9993

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list