NFS over GB ethernet

Mark Hahn hahn at physics.mcmaster.ca
Wed Nov 6 11:53:24 EST 2002


> We are just bringing to life a cluster using Debian over GB
> ethernet. We want to mount /home and /usr/local via nfs but it seems
> that at boot time the GB link isn't up so the mount fails.

Unix is designed to let you do absolutely anything.  in particular,
any serious unix admin should recognize that "boot time" means 
"when the kernel loaded" and ends when the first user-space program,
is run (that's init).  from then on, it's all user-space.  if you
really wanted, you could use somethng like init=/usr/sbin/vmware
and never have any normal user-level linux processes.  or, for that 
matter, a really limited-purpose machine might run init=/bin/myserver.

pardon the soapbox!  the point is that configuring the network and 
mountig net filesystems is the responsibility of the /etc/rc.d/init.d
scripts (linked into /etc/rc.d/rc3.d, probably).  iirc, Debian
uses just /etc/init.d, but the links are otherwise the same.
to impose the ordering you need, make sure the S10network (or whatever)
appears before the S20netfs link.  names will vary, but your problem
is either that you lack the appropriate link entirely (so the NIC 
never gets configured), or it's ordered wrong (happens after the 
attempt to mount nfs filesystems.)

or are you trying to use kernel auto-configuration of the net?

> The mounts
> succeed after the link is up. Do we need a timeo variable in the fstab?

I suspect it's much simpler: just arrange for ifconfig to preceed mounts.

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list