gigabit ethernet card problems - smc9462TX

Donald Becker becker at
Wed Mar 27 17:14:43 EST 2002

On Wed, 27 Mar 2002, Alexis Zubrow wrote:

> I'm a relative newbie to both linux and beowulf clusters.  I am starting
> up a small beowulf cluster.  Until we get some more funding, I have two
> dual processor computers connected with a crossover cable.  I'm using the
> ns83820 driver in the 2.4.17 kernel.  I have not been able to get any real
> connection between the two cards.  Any suggestions would be greatly
> appreciated.
> Dual AMD MP 1800+, Tyan S2460 mother board, SMC9462TX ethernet cards
> Tests:
> -crossover cable is good
> -if connect (with crossover cable) one of the cards to another
> (non-gigabit card), it recognizes and correctly auto negotiates to the new
> media speed.
> -ping between two gigabit cards has 100% packet loss.

I encountered this when writing ns820.c.  (I released ns820.c before
ns83820.c was started, but it's the latter that's in the kernel.)  The
'820 chip has an input pin with the link status of the gigabit
transceiver, but the meaning isn't defined -- it depends on what the
transceiver outputs.  If SMC changed the transceiver, the driver might
be doing exactly the wrong thing.

The ns820.c from driver _might_ work...

Donald Becker				becker at
Scyld Computing Corporation
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list