Redhat bootdisk and Intel E1000?

Rocky McGaugh rocky at atipa.com
Thu Aug 1 13:53:20 EDT 2002


On 1 Aug 2002, Bill Rankin wrote:

> Good morning,
> 
> I have a bunch of nodes that I am trying to kickstart install and I am
> having some slight difficulties. 
> 
> The nodes are Tyan-2466s w/ Intel E1000 GigE cards and a cheap AGP video
> card.
> 
> The machines come up just fine with a RedHat 7.3 boot disk image
> (bootnet.img) using the on-board NIC.  The problem is that I want to
> configure them to boot and install over the E1000 so I can just
> kickstart them at any time without swapping around network cables (the
> E1000 will be the only live interface in the final configuration).
> 
> I ripped apart the bootnet image and added the e1000.o file to the
> module directory (compiled and tested on a working machine), but the
> node would not recognize it on boot.
> 
> Does anyone have experience with attempting this?
> 
> Any advice would be greatly appreciated.  Thanks,
> 
> -bill
> 
> 

There's a PCI device table listing in the boot image somewhere.

you'll have to update it with the PCI vendor string and which module to 
use.

-- 
Rocky McGaugh
Atipa Technologies
rocky at atipatechnologies.com
rmcgaugh at atipa.com
1-785-841-9513 x3110
http://1087800222/
perl -e 'print unpack(u, ".=W=W+F%T:7\!A+F-O;0H`");'

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list