DMA difficulties

Steven Berukoff steveb at aei-potsdam.mpg.de
Sun Apr 14 13:24:24 EDT 2002


Hi,

Sorry, I should have given a bit more info.

If the IDE cable is attached, but the power cable is not, the machine will
not complete POST; it will hang.  If the power cable is attached, but the
IDE cable is not, the machine completes POST, and goes forward with the
install.  However, performance is slow.  Only when both cables are
attached to the CDROM does the installation run quickly.

To address Alvin's comments, all settings in the BIOS relevant to the
CDROM are disabled: the CDROM is not listed as a boot device, it's not a
Master or Slave on either IDE channel, and the Secondary IDE channel is
disabled.  Further, no IDE cables are attached where they shouldn't be,
i.e., only the HDD cable is plugged in.  Finally, there is no option in
the BIOS for enabling/disabling autodetection of IDE devices.

To address Mark's comments, the kernel that I'm using is the 2.4.7-10
kernel that comes with RH7.2.  In particular, I'm using the kernel found
in images/pxeboot, which includes support for the network loopback device,
initial ramdisk, etc.  Also, the boot messages say that the HDD is
DMA enabled, although, as I've said, I'm a bit wary of that pronouncement.

I thought about compiling my own kernel for this, instead of using the RH
distro version.  However, going through some of the permutations of kernel
configurations didn't produce a useful product.  Anyone have insights as
to the kernel config that will work for this, or the options in the stock
RH kernel, or how to extract such options?

TIA again for your insights.

Steve



> hi ya
> 
> i notice that when the cable is attached... things goes
> bonkers... even if no power ot the drive ( hd or cdrom )
> 
> remove the ide cable from the motherboard if its not used
> 
> and tell the bios NOT to autodetect ide devices
> except those that is in fact present
> 
> 150 nodes.... hummm .... one full cabinet..front and back.. :-)
> 
> c ya
> alvin
> http://www.Linux-1U.net
> 
> 
> On Sun, 14 Apr 2002, Steven Berukoff wrote:
> 
> > 
> > Hi all,
> > 
> > This question may be very slightly off-topic, so I apologize.
> > 
> > I'm in the process of setting up a network installation procedure using
> > PXE/DHCP/NFS/Kickstart w/ RH7.2 for about 150 dual Athlon nodes.  These
> > nodes use a Maxtor 6L080J4 80.0GB HDD and an ASUS A7M266-D motherboard,
> > among other things.  One particular note is that I don't need/want CDROMs
> > in these systems.
> > 
> > Now, a vendor provided me with a couple of test nodes basically to our
> > specifications, except that they included CDROMs and floppies.  To make a
> > longish story shorter, I wanted to make sure that the nodes work fine
> > without the CDROM.
> > 
> > So, I first looked into the BIOS.  I disabled (set to "None") Primary
> > Slave, Secondary Master/Slave (since my HDD is Primary Master), removed
> > the CDROM from the list of boot devices, and disabled the Secondary IDE
> > channel.  Then, I passed the kernel args "ide0=dma hdb=none" to try to
> > enforce the HDD to use DMA during the Kickstart installation.
> > 
> > Now, here is the kicker: regardless of the BIOS settings, if I have the
> > CDROM plugged in (power+IDE, on the secondary channel) the installation
> > takes ~ 5 times faster than if the thing isn't there.  This installation
> > includes installation of ~470 packages plus formatting the HDD.  That's
> > right, as long as the CDROM is plugged in, everything is peachy, but once
> > gone, things slow down.
> > 
> > I think this is a problem with the DMA settings, b/c when I pass
> > "ide=nodma" to the kernel, WITH the CD attached, performance is
> > slow.  However, I can't even force DMA to be used.
> > 
> > If anyone has any suggestions or similar experiences, please let me know.
> > 
> > Thanks a bunch!
> > Steve
> > 
> > 
> > =====
> > Steve Berukoff					tel: 49-331-5677233
> > Albert-Einstein-Institute			fax: 49-331-5677298
> > Am Muehlenberg 1, D14477 Golm, Germany		email:steveb at aei.mpg.de
> > 
> > 
> > _______________________________________________
> > Beowulf mailing list, Beowulf at beowulf.org
> > To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf
> > 
> 
> 



=====
Steve Berukoff					tel: 49-331-5677233
Albert-Einstein-Institute			fax: 49-331-5677298
Am Muehlenberg 1, D14477 Golm, Germany		email:steveb at aei.mpg.de



_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list