scyld slave node problems

Donald Becker becker at scyld.com
Thu Apr 11 15:16:47 EDT 2002


On Thu, 11 Apr 2002, Eric Miller wrote:

> >I'm setting up a small cluster for my university using the Scyld distro.
> >The master is up and running and now I'm trying to get the nodes to
> operate.
> >However, the node I'm currently working on is having some difficulties. It
> >seems to be communicating with the master just fine, but when copying the
> >libraries from the master it starts spitting out "try_do_free_pages failed
> >for init" and similar messages.

My first guess is that you don't have enough memory (64MB+) on the slave
node.  But this might also be a memory or disk problem.

> There might be a more technical solution, but I had the same problem and was
> able to solve it by booting that node diskless.  Just disconnect the hard
> drive, and re-boot with the boot disk.  Like I said, there may be a better
> way or technical solution, but ".....free_pages" led me to believe it was a
> HDD problem.  I booted diskless, and had no problems.

You should not need to physically disconnect the hard disk.  Just remove
any references to /dev/hda that you added in /etc/beowulf/fstab.
However if you do have a hardware problem, disconnecting the disk might
avoid the symptoms.

-- 
Donald Becker				becker at scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list