Newest RPM's?

Robert G. Brown rgb at phy.duke.edu
Thu Apr 11 11:54:51 EDT 2002


On 10 Apr 2002, Peter Bowen wrote:

> Are there beowulf packages available for RHL7.2?

Depends on what you mean.  Some of the fundamental tools (PVM, flavors
of MPI, more) are already packaged in and in 7.2.  Ditto the full range
of GPL compilers and programming support tools.  Even commercial beowulf
packages like scyld or a turnkey vendor's arrangement often use RH as a
base, although they aren't always current with the very latest release.

Pretty much all the truly open source beowulf tools either are available
in rpm form that will install under 7.2 (or source rpm that will rebuild
and install under 7.2) or at the very least and worst in a tarball form
that will build and install under any unixoid/posix environment
including 7.2.  In fact, it is almost tautological that this would be so
-- beowulf tools were mostly developed on linux/gnu boxes and RH is at
heart a generic linux/gnu distribution.

Commercial packages (e.g. portland or absoft compilers, PBS-Pro) can
almost always be obtained in a form that runs under 7.2.  The only
exceptions are likely to be ones with library issues that haven't yet
been ported.  libc has from time to time changed enough to break things,
so tools developed on e.g. RH 5.2 don't always work on 7.2 without some
porting effort (but I know of no mainstream tools in this category).

So I think the answer would have to be "yes";-)

   rgb

-- 
Robert G. Brown	                       http://www.phy.duke.edu/~rgb/
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525     email:rgb at phy.duke.edu



_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list