NIS server core dump

Jacques B. Siboni jacsib at lutecium.org
Fri Sep 28 09:39:53 EDT 2001


Hi all,

I use ypserv on the Linux 7.0 box to serv the NIS clients on the slave
machines. ypserv version is ypserv-1.3.12 (previous versions act the same
way).

ypserv starts ok. but as soon as I try to access to the service I get a
segmentation fault and core dump.

A simple command as 
rpcinfo -u localhost ypserv
generates the problem.

The conf files are very simple.

The funny thing is that it seems to serv ok but crashes then. For instance the
command 'ypbind' produces to ypserv -d:

[root at lutecium /root]# ypserv -d
[Welcome to the NYS YP Server, version 1.3.12 (with securenets)]
Find securenet: 255.0.0.0 127.0.0.0
Find securenet: 0.0.0.0 0.0.0.0
ypserv.conf: 0.0.0.0/0.0.0.0:*:0:0:2
ypproc_domain_nonack("nis.lutecium") [From: 192.168.1.1:3142]
connect from 192.168.1.1
        -> OK.
Segmentation fault (core dumped)


as you see it connects ok and then crashes.

Does anyone have the experience of this kind of thing or can direct me to a
place where I can find an answer

Thanks in advance

Jacques



-- 
Dr. Jacques B. Siboni mailto:jacsib at Lutecium.org
8 pass. Charles Albert, F75018 Paris, France
Tel. & Fax: 33 (0) 1 42 28 76 78
Home Page: http://www.lutecium.org/jacsib/

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list