RH7.1,portmap, yp,nfs (again)

Jeremy P. Mann jeremy at bioc09.v19.uthscsa.edu
Fri Jun 22 09:26:23 EDT 2001


On Thu, 21 Jun 2001, Georgia Southern Beowulf Cluster Project wrote:

> Monday: Everything goes to hell.  When I add users or change NIS maps and
> then "cd /var/yp; make" every map tells me something about RPC portmap
> failure or can't export maps.  ypserv and ypbind are running fine on the
> master server (where these events take place).  When I run ypinit -s
> <server> on each of my YP slave servers, they say that they cannot enumerate
> maps, make sure it is running on <server>.  It is, I've quadruple checked
> it, even putting the master ypserv process in debug mode.  Also, going to
> single user mode and then coming back to console runlevel shows me that
> ypbind now cannot bind to the domain server, which IS running ypserv.  Also,
> even when I can bind to the master server on all the other servers, the
> nodes are not receiving the yp maps from their slave servers.  Also, NFS
> stuff goes haywire, complaining about RPC, portmap, and not being able to
> register or get slots.  Solution: go home, eat dinner, nap, come back
> refreshed.  When I come back a few hours later, EVERYTHING WORKS.  Its like
> nothing happened.  I an again lamboot and run the pi program on 64 machines.

Encountered this yp problem a couple days ago. I too had the same problem
when adding users. Before you run ypmake make sure shadow is off. If not
shadow will not include the +++ at the end of the /etc/passwd file.

Hope this helps.


-- 
Jeremy Mann
jeremy at bioc09.v19.uthscsa.edu


_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list