Help!!!About Channel Bonding!

Jakob Østergaard jakob at unthought.net
Thu Jun 21 12:20:15 EDT 2001


On Thu, Jun 21, 2001 at 07:30:11PM +0800, ÁõöÎ½Ü wrote:
> Hello,everyone.I have construct a set of Beowulf system.But the task of 
> channel bonding  can not be solved.My system is:
> 	one frontend node used as gateway,four computing nodes.I used three intel 
> EEPro100 NIC cards in frontend and each computing  nodes ,and one extra NE2000 PCI on 
> frontend to connect with internet.I use one Intel 460T swither(16 ports).And I want 
> to bong every three NIC cards to archive a better performance.So I use the 
> "ifenslave".I write the ifcfg-bond0 and ifcfg-eth0~2 scripts.And "ifconfig" can find 
> the "bond0" device.But I find that there is a very bad performance existed(about 
> 100B/s).And I archive  4MB/s if I use only one NIC in each machine.
> 	My IP :
> 	Frontend: in 192.168.0.254
> 	Computing node:	192.168.0.1
> 			192.168.0.2
> 			192.168.0.3
> 			192.168.0.4
> 	Swither:	192.168.0.253
>  	So,can someone tell me what is wrong:Can the Intel 460T support channel 
> bonding ?Does using channel bonding mean use more than one swither?

I use channel bonding with Intel 460T switches here.  It works beautifully.

First, make sure that the bonding is set up properly on your linux machines. On a
machine here with two NICs it looks like:
[phoenix:joe] $ /sbin/ifconfig 
bond0     Link encap:Ethernet  HWaddr 00:D0:B7:40:7E:DC  
          inet addr:10.0.0.9  Bcast:10.0.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:485442352 errors:0 dropped:68 overruns:0 carrier:0
          collisions:0 txqueuelen:0 

eth0      Link encap:Ethernet  HWaddr 00:D0:B7:40:7E:DC  
          inet addr:10.0.0.9  Bcast:10.0.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:703034599 errors:1186 dropped:0 overruns:1816 frame:0
          TX packets:242721183 errors:0 dropped:0 overruns:1351 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:19 Base address:0x6000 

eth1      Link encap:Ethernet  HWaddr 00:D0:B7:40:7E:DC  
          inet addr:10.0.0.9  Bcast:10.0.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:55577121 errors:6 dropped:0 overruns:3 frame:0
          TX packets:242721169 errors:0 dropped:0 overruns:1359 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:18 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2389608 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2389608 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 


If you have problems with that - maybe your init-scripts are wrong.  On RedHat 7.1 my
init-scripts look like:
[phoenix:joe] $ cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE="eth0"
BOOTPROTO="none"
ONBOOT="yes"
MASTER=bond0
SLAVE=yes
[phoenix:joe] $ cat /etc/sysconfig/network-scripts/ifcfg-eth1 
DEVICE="eth1"
BOOTPROTO="none"
ONBOOT="yes"
MASTER=bond0
SLAVE=yes
[phoenix:joe] $ cat /etc/sysconfig/network-scripts/ifcfg-bond0 
DEVICE="bond0"
BOOTPROTO="none"
ONBOOT="yes"
IPADDR="10.0.0.9"
NETMASK="255.255.255.0"


Last but not least, you want to make sure that your switch is configured
properly.

On the Intel 460T YOU SHOULD **NOT** SET UP TRUNKING.   If you set up trunking
you will see that only one network adapter is used for RX, while all adapters
(since they're controlled by the linux kernel which works properly) will do TX.

If you just plug in the NICs, trunking/bundling will work out of the box.

If you actively configure this on the switch, it will not work.  Oh, the irony    ;)

However, even configuring it on the switch should not cause packet loss, like it
seems you are experiencing.   I suggest you double-check your linux setup first.

If you keep having trouble - please try configuring this up on two NICs in each
machine only.  I have this working today on the Intel 460T  -  I haven't tried
with more NICs.

-- 
................................................................
:   jakob at unthought.net   : And I see the elder races,         :
:.........................: putrid forms of man                :
:   Jakob Østergaard      : See him rise and claim the earth,  :
:        OZ9ABN           : his downfall is at hand.           :
:.........................:............{Konkhra}...............:

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list