Channel-bonding/VLANs

R C zarquon at zarq.dhs.org
Tue Jul 10 18:14:33 EDT 2001


On Tue, Jul 10, 2001 at 03:31:30PM -0500, Mike Weller wrote:
> Hello,
> 
> I'd like to update you all on my progress so far.  Apparently, even
> though the HP4000 Procurve switches support VLAN's, having duplicate
> MAC addresses on different VLANs must have been confusing it.
> Theoretically, non-overlapping VLANs should behave as independent
> switches, but they don't in reality.
 
We have very nearly the exact same configuration as you do for our 
cluster; one week during downtime I had a chance to play with channel 
bonding. We have an HP 4000 Procurve for the cluster, and a 24xx for
the lab in general.

As you found out, the HPs don't support duplicate NATs on seperate 
VLANs (even states this in the manual, but I had to dig to find it).
At that point I borrowed the lab switch and hooked it in.  Using
2.4.x, and 2 channels, I got about 160-170 Mbps with an Intel eepro100
(onboard) and an Adaptec duralan (starfire?) card.  The adaptec
tended to hiccup and give "Something Wicked Happened!" during full
speed tests, but rarely pulled down below 150 Mbps.

Tests were done using ttcp, linux 2.4.4?, and Dell server boxes
(dual 500, 512MB).

Preliminary linpack tests showed a slight slowdown.  This was
never resolved, as the cluster was needed for cpu/memory bound sims.

R C

_______________________________________________
Beowulf mailing list, Beowulf at beowulf.org
To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list