PVM Problems

JParker at coinstar.com JParker at coinstar.com
Mon Apr 30 11:52:56 EDT 2001


G'Day !

I am running PVM (I believe it is the 3.4 version) on a Debian 2.2 system 
using Bash for my shell.  I configured it as per the man pages and the MIT 
reference book, except I defined PVM_ROOT and PVM_ARCH in .bashrc on every 
node (including the head server) and not the .cshrc .  Should I put in my 
.bash_profile on the head node ?  I also have my .rhosts correct, as 
verified by running rsh and ssh.

The symptoms are that when I run the pvm shell, it starts correctly on the 
server, as verified by running administrative commands, but when I try to 
add a node, it returns a "terminated" and puts me back at my bash shell 
prompt.  I can then rsh or ssh over to the node and verify the pvmd is 
running on the node via the ps command.  When I try to use the pvm shell 
on that node, it displays a notice that the pvmd is already running and 
hangs till I kill the process.  Any clues or suggestions ?

Another question is that the docs say there should be a lock file in /tmp, 
but what I find is a directory containing a log file (and of course no 
indication why I can not add the node).  Is this the normal setup ?  BTW, 
I can restart pvm at on the server and launch another instance of the 
dameon on the node with similar results as stated above.

Final question (for now), how do I set PVM up to use ssh instead of rsh ?

cheers,
Jim Parker

Sailboat racing is not a matter of life and death ....  It is far more 
important than that !!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.clustermonkey.net/pipermail/beowulf/attachments/20010430/779b83d8/attachment.html>


More information about the Beowulf mailing list