"beoserv" daemon not reacting to slave rarp requests ...

Richard Walsh rbw at networkcs.com
Tue Nov 21 16:47:08 EST 2000


All,

I am trying to bring up the slave nodes from the 
head node using Beowulf-2 software from Scyld. I am
following the documentation carefully. 

"beoserv" (listening from eth0 on port 2223) and bpmaster 
seem to come up without trouble. The config file is correct
(eth0 is the internal address 10.0.0.17, eth1 is a second
internal network for file transfers only, and eth2 is external)
Range (10.0.0.1 10.0.0.16) and netmask are specified correctly.

The slave nodes boot from floppy and begin r-arping.
This is clear from the lights on the interfaces and
a tcpdump on the head node. At this point, the config 
file in /etc/beowulf/config should be updated ... but this 
never happens ... the slave nodes just r-rarp forever. 

I am assuming that bpmaster and beoserv take care of all 
that is required to assign the IP address out of the specified 
range in the config file, but perhaps I am wrong ... does 
some other service have to be running?

Suggestions appreciated ...

Richard Walsh

#---------------------------------------------------
#
# Richard Walsh
# Project Manager
# netASPx, Inc.
# 1200 Washington Ave. So.
# Minneapolis, MN 55415
# VOX:    612-337-3467
# FAX:    612-337-3400
# EMAIL:  rbw at networkcs.com, richard.walsh at netaspx.com
#
#---------------------------------------------------
# "What you can do, or dream you can, begin it;
#  Boldness has genius, power, and magic in it."
#                                       -Goethe
#---------------------------------------------------


_______________________________________________
Beowulf mailing list
Beowulf at beowulf.org
http://www.beowulf.org/mailman/listinfo/beowulf



More information about the Beowulf mailing list