From the Open MPI Team -- go team

The Open MPI Team, representing a consortium of research, academic, and industry partners, is pleased to announce the release of Open MPI version 3.0.0.

v3.0.0 is the start of a new release series for Open MPI. Open MPI 3.0.0 enables MPI_THREAD_MULTIPLE by default, so a build option to Open MPI is no longer required to enable thread support. Additionally, the embedded PMIx runtime has been updated to 2.1.0 and the embedded hwloc has been updated to 1.11.7. There have been numerous other bug fix and performance improvements. Version 3.0.0 can be downloaded from the main Open MPI web site.

NEWS:

Major new features:
  • Use UCX allocator for OSHMEM symmetric heap allocations to optimize intra-node data transfers. UCX SPML only.
  • Use UCX multi-threaded API in the UCX PML. Requires UCX 1.0 or later.
  • Added support for Flux PMI
  • Update embedded PMIx to version 2.1.0
  • Update embedded hwloc to version 1.11.7

Changes in behavior compared to prior versions:

  • Per Open MPI's versioning scheme (see the README), increasing the major version number to 3 indicates that this version is not ABI-compatible with prior versions of Open MPI. In addition, there may be differences in MCA parameter names and defaults from previous releases. Command line options for mpirun and other commands may also differ from previous versions. You will need to recompile MPI and OpenSHMEM applications to work with this version of Open MPI.
  • With this release, Open MPI supports MPI_THREAD_MULTIPLE by default.
  • New configure options have been added to specify the locations of libnl and zlib.
  • A new configure option has been added to request Flux PMI support.
  • The help menu for mpirun and related commands is now context based. "mpirun --help compatibility" generates the help menu in the same format as previous releases.

Removed legacy support:

  • AIX is no longer supported.
  • Loadlever is no longer supported.
  • OpenSHMEM currently supports the UCX and MXM transports via the ucx and ikrit SPMLs respectively.
  • Remove IB XRC support from the OpenIB BTL due to lack of support.
  • Remove support for big endian PowerPC.
  • Remove support for XL compilers older than v13.1

Known issues:

  • MPI_Connect/accept between applications started by different mpirun commands will fail, even if ompi-server is running.

You have no rights to post comments

Search

Login And Newsletter

Create an account to access exclusive content, comment on articles, and receive our newsletters.

Feedburner

Share The Bananas


Creative Commons License
©2005-2016 Copyright Seagrove LLC, Some rights reserved. Except where otherwise noted, this site is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.5 License. The Cluster Monkey Logo and Monkey Character are Trademarks of Seagrove LLC.